Tuniac 160913

The Tuniac forum.
Post Reply
Brett
Site Admin
Posts: 250
Joined: Sun Mar 28, 2010 12:36 am

Tuniac 160913

Post by Brett » Tue Sep 13, 2016 12:26 pm

Sep, 2016
---------
-fix sort after initial import if playlist file was found
-add warning to nfn export plugin about duplicating files
-improve array building on startup
-fix x64 setup to offer x64 option
-more BASS utf8 instead of auto codepage
-redo how shuffle array is built. Simpler and faster?
-Add prefs for play controls line 1/2

Download:
http://www.tuniac.org/Release/160913/
OR
http://sourceforge.net/projects/tuniac/ ... ac/160913/

Harteex
Posts: 80
Joined: Tue Mar 30, 2010 7:23 pm

Re: Tuniac 160913

Post by Harteex » Thu Sep 15, 2016 8:48 am

I'm having frequent crashes on song change. Just letting it play a few songs, and it will crash when changing to the next.
No difference with crossfade on or off. With crossfade on it will start to cross fade but when the actual song change happens, it will crash.

Windows 10 x64, Tuniac x64.

I tried to delete and recreate my song library and no difference.

Btw, I also have crashing problems with the previous version (where you fixed the x64 installer).

Brett
Site Admin
Posts: 250
Joined: Sun Mar 28, 2010 12:36 am

Re: Tuniac 160913

Post by Brett » Thu Sep 15, 2016 9:19 am

But not the build before that?

Does 32bit of the newer builds crash?

Can you give the exact crash message and any error codes it gives?

Harteex
Posts: 80
Joined: Tue Mar 30, 2010 7:23 pm

Re: Tuniac 160913

Post by Harteex » Thu Sep 15, 2016 9:52 am

It seems like there are specific songs (but multiple) that crash, under some circumstances.
I'll PM you a link to two songs. Play the first song and when it finishes and goes onto the next it crashes for me.
You can seek forward with Winkey + 3, but if you try to skip most of it by clicking in the progressbar it will surprisingly not crash.

As for error message, it just says "Tuniac Media player has stopped working".

I don't remember which build I ran when it worked unfortunally, it's possible I've missed a few upgrades and used an even older build.
If you can reproduce it with those two songs, great. Otherwise I will try 32bits and more previous versions.

I also tried to remove the folder.jpg I have, but that doesn't make any difference.

Brett
Site Admin
Posts: 250
Joined: Sun Mar 28, 2010 12:36 am

Re: Tuniac 160913

Post by Brett » Thu Sep 15, 2016 11:40 am

Test 160915 from http://wasteofcash.com/Tuniac/

Can you enable logging.
View -> Log Window -> Enable Logging at the bottom
Tuniac will not remember this setting after closing.
You do not need to remain on this screen.

Tell me if you get BASS_Plugin error codes come up.
0 and 45 are fine, but do prove how dumb my code was before :p

Hopefully the problem will be gone and I can facepalm over just how dumb this was for so long.

Harteex
Posts: 80
Joined: Tue Mar 30, 2010 7:23 pm

Re: Tuniac 160913

Post by Harteex » Thu Sep 15, 2016 12:33 pm

Brett wrote:Tell me if you get BASS_Plugin error codes come up.
0 and 45 are fine, but do prove how dumb my code was before :p
I don't see any BASS_Plugin error at all :)
Just CoreAudio: SetSource and AlbumArt: SetSource.
I also tried another file with the same problem and that works too.
Thanks for the fix :)
Brett wrote:Hopefully the problem will be gone and I can facepalm over just how dumb this was for so long.
You realize when you write like that, you just have to write what the bug was ;)

Brett
Site Admin
Posts: 250
Joined: Sun Mar 28, 2010 12:36 am

Re: Tuniac 160913

Post by Brett » Thu Sep 15, 2016 12:35 pm

Uhh try 160915a if you actually want the log to log what I wanted.

Brett
Site Admin
Posts: 250
Joined: Sun Mar 28, 2010 12:36 am

Re: Tuniac 160913

Post by Brett » Thu Sep 15, 2016 12:40 pm

Problem is that I did not check that BASS actually returned success.
My code assumed success and did not check for an error.
For me on 64bit BASS likes to return an error of end of file(error 45) for your files.

Tuniac checks with BASS earlier for if the file had ended and also would have accepted BASS returning 0 audio.

I am not sure why BASS 64bit likes to behave like this, but it is my code that did not check for the error.

Harteex
Posts: 80
Joined: Tue Mar 30, 2010 7:23 pm

Re: Tuniac 160913

Post by Harteex » Thu Sep 15, 2016 12:43 pm

Ah I see.

Yea, I get BASS_Plugin: Error code 45 after some songs. No other error.

Post Reply